Medium severity · published May 13, 2026
CVE-2026-44580
Next.js: Cross-site scripting in beforeInteractive scripts with untrusted input
6.1
CVSS
0.2%
EPSS
No
On KEV
Description
Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 10% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NE
next.js · vercel
>= 13.0.0, < 15.5.16; >= 16.0.0, < 16.2.5 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-44580
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-44580
Mitigation
https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h
More from next.js
10.0
CVE-2025-55182
Meta React Server Components Remote Code Execution Vulnerability
9.1
CVE-2025-29927
Next.js is a React framework for building full-stack web applications
9.0
CVE-2026-75604
Next.js: Unauthenticated Remote Code Execution on windows-hosted servers
8.6
CVE-2026-44578
Next.js: Server-side request forgery in applications using WebSocket upgrades
8.2
CVE-2026-94482
Next.js: Denial of Service in App Router using Server Actions
