Medium severity · published Jul 30, 2026
CVE-2026-23985
Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser
6.5
CVSS
0.7%
EPSS
No
On KEV
Description
A Regular Expression Denial of Service (ReDoS) vulnerability exists in Apache Superset versions 1.5.0 through 5.0.0. The vulnerability is located in the sql_parse.py component, specifically within the SQL_REGEX used for parsing SQL statements in the sqlparse library integration.
The affected regular expression contains overlapping disjunctions that share a common outer quantifier. An authenticated attacker can exploit this by sending a maliciously crafted input string (specifically a long sequence of backslashes or similar characters) to endpoints that process SQL queries
This issue affects Apache Superset: before 6.0.0.
Users are recommended to upgrade to version 6.0.0, which fixes the issue.
Workarounds:
● WAF Rules: Implement Web Application Firewall (WAF) rules to detect and block
requests containing excessively long sequences of backslashes or suspicious repeated
patterns in the queries.extras.where parameter.
● Rate Limiting: Ensure strict rate limiting is applied to the /api/v1/chart/data endpoint to
reduce the impact of potential attacks.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 51% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AS
Apache Superset · Apache Software Foundation
before 6.0.0 · source: vendor
SU
Superset · Apache
1.5.0 before 6.0.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-23985
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-23985
Mailing List
https://lists.apache.org/thread/fdy7tx7glv90ypd7qnm1g1pt7nn336qx
Mailing List
http://www.openwall.com/lists/oss-security/2026/07/30/7
More from Apache Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
6.5
CVE-2026-23969
Apache Superset: Exposure of Sensitive Information via Incomplete ClickHouse Function Filtering
6.5
CVE-2026-23980
Apache Superset: Improper Neutralization of Special Elements used in a SQL Command
6.5
CVE-2026-23982
Apache Superset: Improper Authorization in Dataset Creation Allows Access Control Bypass
6.5
CVE-2026-23983
Apache Superset: Sensitive Data Exposure via REST API (disabled by default)
