Medium severity · published Feb 24, 2026
CVE-2026-23982
Apache Superset: Improper Authorization in Dataset Creation Allows Access Control Bypass
6.5
CVSS
0.5%
EPSS
No
On KEV
Description
An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 44% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AS
Apache Superset · Apache Software Foundation
0.0.0 before 6.0.0 · source: vendor
SU
Superset · Apache
before 6.0.0 · source: NVD
Affected product
AS
Apache Superset
Apache Software Foundation
More from Apache Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
6.5
CVE-2026-23985
Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser
6.5
CVE-2026-23969
Apache Superset: Exposure of Sensitive Information via Incomplete ClickHouse Function Filtering
6.5
CVE-2026-23980
Apache Superset: Improper Neutralization of Special Elements used in a SQL Command
6.5
CVE-2026-23983
Apache Superset: Sensitive Data Exposure via REST API (disabled by default)