Low severity · published Oct 26, 2026
CVE-2026-115917
vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server
New
3.4
CVSS
0.2%
EPSS
No
On KEV
Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
None
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 15% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VL
vllm · vllm-project
< 0.32.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-115917
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-115917
github.com
https://github.com/vllm-project/vllm/commit/fcae5c98870ff2c20659731dce7ba3a3ff0d48aa
github.com
https://github.com/vllm-project/vllm/pull/61009
github.com
https://github.com/vllm-project/vllm/releases/tag/v0.32.0
github.com
https://github.com/vllm-project/vllm/security/advisories/GHSA-vvpg-rrww-wpmh
More from vllm
9.8
CVE-2024-9053
vllm-project vllm version 0.6.0 contains a vulnerability in the AsyncEngineRPCServer() RPC server entrypoints
9.1
CVE-2026-48746
vLLM: OpenAI auth bypass
8.8
CVE-2026-54232
vLLM: Dependency Confusion Vulnerability in vLLM Dockerfile
8.2
CVE-2026-116176
vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector
8.1
CVE-2026-115915
vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
