Medium severity · published Oct 6, 2026
CVE-2026-106491
Backstage: Improper input validation in proxy-backend
6.4
CVSS
0.3%
EPSS
No
On KEV
Description
Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 20% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BA
backstage · backstage
< 1.54.6 · source: vendor, NVD
PL
plugin-proxy-backend · @backstage
< 0.6.17 · source: vendor
BA
Backstage/plugin-proxy-backend · Linuxfoundation
before 0.6.17 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-106491
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-106491
x_refsource_CONFIRM
https://github.com/backstage/backstage/security/advisories/GHSA-9ghw-48h5-v2w5
x_refsource_MISC
https://github.com/backstage/backstage/commit/233287d0ce3133e41549bf92a7470c940a41753c
x_refsource_MISC
https://github.com/backstage/backstage/releases/tag/v1.54.6
More from plugin-proxy-backend
6.5
CVE-2026-106456
Backstage: Inconsistent credential enforcement for overlapping proxy routes
