Medium severity · published Oct 6, 2026
CVE-2026-106456
Backstage: Inconsistent credential enforcement for overlapping proxy routes
6.5
CVSS
0.2%
EPSS
No
On KEV
Description
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 15% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BA
backstage · backstage
>= 1.28.0, < 1.55.0 · source: vendor, NVD
PL
plugin-proxy-backend · @backstage
>= 0.5.0, < 0.6.18 · source: vendor
BA
Backstage/plugin-proxy-backend · Linuxfoundation
0.5.0 before 0.6.18 · source: NVD