Medium severity · published Jan 28, 2026
CVE-2025-67723
Discourse vulnerable to stored Cross-site Scripting via Katex in discourse-math plugin
5.4
CVSS
0.2%
EPSS
No
On KEV
Description
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 12% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DI
discourse · discourse
< 3.5.4; >= 2025.11.0-latest, < 2025.11.2; >= 2025.12.0-latest, < 2025.12.1; >= 2026.1.0-latest, < 2026.1.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-67723
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-67723
Vendor Advisory
https://github.com/discourse/discourse/security/advisories/GHSA-955h-m28g-5379
More from discourse
9.9
CVE-2025-68662
FinalDestination hostname matching allows SSRF protection bypass
9.8
CVE-2025-53102
Discourse is an open-source community discussion platform
9.8
CVE-2025-48877
Discourse is an open-source discussion platform
9.8
CVE-2023-47121
Discourse is an open source platform for community discussion
9.8
CVE-2021-41163
Discourse is an open source platform for community discussion
