Critical severity · published Jun 9, 2025
CVE-2025-48877
Discourse is an open-source discussion platform
9.8
CVSS
0.4%
EPSS
No
On KEV
Description
Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 35% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DI
Discourse · Discourse
before 3.4.4; before 3.5.0; 3.5.0; 3.5.0; 3.5.0; 3.5.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-48877
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-48877
Vendor Advisory
https://github.com/discourse/discourse/security/advisories/GHSA-cm93-6m2m-cjcv
More from Discourse
9.9
CVE-2025-68662
FinalDestination hostname matching allows SSRF protection bypass
9.8
CVE-2025-53102
Discourse is an open-source community discussion platform
9.8
CVE-2023-47121
Discourse is an open source platform for community discussion
9.8
CVE-2021-41163
Discourse is an open source platform for community discussion
9.3
CVE-2026-55674
Discourse: Cache poisoning/XSS via color scheme cookies
