Medium severity · published Nov 25, 2025
CVE-2025-65961
Contao is vulnerable to cross-site scripting in templates
4.8
CVSS
0.2%
EPSS
No
On KEV
Description
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 7% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CO
contao · contao
>= 4.0.0, < 4.13.57; >= 5.0.0-RC1, < 5.3.42; >= 5.4.0-RC1, < 5.6.5 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-65961
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-65961
Vendor Advisory
https://contao.org/en/security-advisories/cross-site-scripting-in-templates
Vendor Advisory
https://github.com/contao/contao/security/advisories/GHSA-68q5-78xp-cwwc
More from contao
9.8
CVE-2022-26265
Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE) vulnerability via the component php_cli parameter
9.8
CVE-2019-11512
Contao 4.x allows SQL Injection
9.3
CVE-2026-107845
Contao: Cross-site scripting in the comments bundle
8.8
CVE-2024-45398
Contao is an Open Source CMS
8.8
CVE-2012-4383
contao prior to 2.11.4 has a sql injection vulnerability
