High severity · published Sep 17, 2024
CVE-2024-45398
Contao is an Open Source CMS
8.8
CVSS
0.5%
EPSS
No
On KEV
Description
Contao is an Open Source CMS. In affected versions a back end user with access to the file manager can upload malicious files and execute them on the server. Users are advised to update to Contao 4.13.49, 5.3.15 or 5.4.3. Users unable to update are advised to configure their web server so it does not execute PHP files and other scripts in the Contao file upload directory.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 45% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CO
Contao · Contao
4.0.0 before 4.13.49; 5.0.0 before 5.3.15; 5.4.0 before 5.4.3 · source: NVD
Affected product
CO
Contao
Contao
More from Contao
9.8
CVE-2022-26265
Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE) vulnerability via the component php_cli parameter
9.8
CVE-2019-11512
Contao 4.x allows SQL Injection
9.3
CVE-2026-107845
Contao: Cross-site scripting in the comments bundle
8.8
CVE-2012-4383
contao prior to 2.11.4 has a sql injection vulnerability
8.8
CVE-2019-19745
Contao 4.0 through 4.8.5 allows PHP local file inclusion