High severity · published Jan 10, 2026
CVE-2025-62235
Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing
8.1
CVSS
0.4%
EPSS
No
On KEV
Description
Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Adjacent
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 31% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NI
Nimble · Apache
before 1.9.0 · source: NVD
Affected product
AM
Apache Mynewt NimBLE
Apache Software Foundation
More from Apache Mynewt NimBLE
7.5
CVE-2025-52435
Apache Mynewt NimBLE: Invalid error handling in pause encryption procedure in NimBLE controller
7.5
CVE-2025-53477
Apache Mynewt NimBLE: NULL Pointer Dereference in NimBLE host HCI layer
3.1
CVE-2025-53470
Apache Mynewt NimBLE: Out-of-Bounds Write Vulnerability in NimBLE HCI H4 driver