Low severity · published Jan 10, 2026
CVE-2025-53470
Apache Mynewt NimBLE: Out-of-Bounds Write Vulnerability in NimBLE HCI H4 driver
3.1
CVSS
0.3%
EPSS
No
On KEV
Description
Out-of-bounds Read vulnerability in Apache NimBLE HCI H4 driver. Specially crafted HCI event could lead to invalid memory read in H4 driver. This issue affects Apache NimBLE: through 1.8.  This issue requires a broken or bogus Bluetooth controller and thus severity is considered low. Users are recommended to upgrade to version 1.9, which fixes the issue.
CVSS vector
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Attack vector
Adjacent
Complexity
High
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 28% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NI
Nimble · Apache
before 1.9.0 · source: NVD
Affected product
AM
Apache Mynewt NimBLE
Apache Software Foundation
More from Apache Mynewt NimBLE
8.1
CVE-2025-62235
Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing
7.5
CVE-2025-52435
Apache Mynewt NimBLE: Invalid error handling in pause encryption procedure in NimBLE controller
7.5
CVE-2025-53477
Apache Mynewt NimBLE: NULL Pointer Dereference in NimBLE host HCI layer