High severity · published Nov 21, 2025
CVE-2025-62164
VLLM deserialization vulnerability leading to DoS and potential RCE
8.8
CVSS
1%
EPSS
No
On KEV
Description
vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 61% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VL
vllm · vllm-project
>= 0.10.2, < 0.11.1 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-62164
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-62164
Patch
https://github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b
Issue Tracking
https://github.com/vllm-project/vllm/pull/27204
Issue Tracking
https://github.com/vllm-project/vllm/security/advisories/GHSA-mrw7-hf4f-83pf
More from vllm
9.8
CVE-2026-115915
vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
9.8
CVE-2026-25960
SSRF Protection Bypass in vLLM
9.8
CVE-2026-22778
vLLM leaks a heap address when PIL throws an error
9.8
CVE-2026-22807
vLLM affected by RCE via auto_map dynamic module loading during model initialization
9.8
CVE-2025-47277
vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
