Medium severity · published Nov 29, 2025
CVE-2025-61915
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems
6.7
CVSS
0.5%
EPSS
No
On KEV
Description
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
High
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 40% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CU
Cups · Openprinting
before 2.4.15 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-61915
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-61915
Patch
https://github.com/OpenPrinting/cups/commit/db8d560262c22a21ee1e55dfd62fa98d9359bcb0
Release Notes
https://github.com/OpenPrinting/cups/releases/tag/v2.4.15
Exploit
https://github.com/OpenPrinting/cups/security/advisories/GHSA-hxm8-vfpq-jrfc
Mailing List
http://www.openwall.com/lists/oss-security/2025/11/27/5
More from Cups
8.0
CVE-2025-58060
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems
7.8
CVE-2026-34990
OpenPrinting CUPS: Local print admin token disclosure using temporary printers
7.5
CVE-2026-34980
OpenPrinting CUPS: Shared PostScript queue lets anonymous Print-Job requests reach `lp` code execution over the network
7.1
CVE-2023-34241
OpenPrinting CUPS is a standards-based, open source printing system for Linux and other Unix-like operating systems
7.0
CVE-2023-4504
Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code…
