High severity · published Sep 21, 2023
CVE-2023-4504
Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code…
7.0
CVSS
0.6%
EPSS
No
On KEV
Description
Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
High
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 50% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CU
Cups · Openprinting
before 2.4.7 · source: NVD
DL
Debian Linux · Debian
10.0 · source: NVD
FE
Fedora · Fedoraproject
37; 38; 39 · source: NVD
LI
Libppd · Openprinting
2.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-4504
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-4504
Release Notes
https://github.com/OpenPrinting/cups/releases/tag/v2.4.7
Exploit
https://github.com/OpenPrinting/cups/security/advisories/GHSA-pf5r-86w9-678h
Exploit
https://github.com/OpenPrinting/libppd/security/advisories/GHSA-4f65-6ph5-qwh6
Mailing List
https://lists.debian.org/debian-lts-announce/2023/09/msg00041.html
Mailing List
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5WHEJIYMMAIXU2EC35MGTB5LGGO2FFJE/
Mailing List
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5WVS4I7JG3LISFPKTM6ADKJXXEPEEWBQ/
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
