Medium severity · published Jul 2, 2025
CVE-2025-46647
A vulnerability of plugin openid-connect in Apache APISIX
5.3
CVSS
0.5%
EPSS
No
On KEV
Description
A vulnerability of plugin openid-connect in Apache APISIX.
This vulnerability will only have an impact if all of the following conditions are met:
1. Use the openid-connect plugin with introspection mode
2. The auth service connected to openid-connect provides services to multiple issuers
3. Multiple issuers share the same private key and relies only on the issuer being different
If affected by this vulnerability, it would allow an attacker with a valid account on one of the issuers to log into the other issuer.
This issue affects Apache APISIX: until 3.12.0.
Users are recommended to upgrade to version 3.12.0 or higher.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
High
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 41% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AP
Apisix · Apache
before 3.12.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-46647
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-46647
Mailing List
https://lists.apache.org/thread/yrpp2cd3o4qkxlrh421mq8gsrt0k4x0w
www.openwall.com
http://www.openwall.com/lists/oss-security/2025/07/02/1
More from Apisix
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
7.5
CVE-2023-44487
HTTP/2 Rapid Reset Attack Vulnerability
9.8
CVE-2022-25757
In Apache APISIX before 2.13.0, when decoding JSON with duplicate keys, lua-cjson will choose the last occurred value as the result
9.3
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
