Medium severity · published Mar 20, 2025
CVE-2025-27888
Apache Druid: Server-Side Request Forgery and Cross-Site Scripting
5.4
CVSS
1.8%
EPSS
No
On KEV
Description
Severity: medium (5.8) / important Server-Side Request Forgery (SSRF), Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'), URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache Druid. This issue affects all previous Druid versions. When using the Druid management proxy, a request that has a specially crafted URL could be used to redirect the request to an arbitrary server instead. This has the potential for XSS or XSRF. The user is required to be authenticated for this exploit. The management proxy is enabled in Druid's out-of-box configuration. It may be disabled to mitigate this vulnerability. If the management proxy is disabled, some web console features will not work properly, but core functionality is unaffected. Users are recommended to upgrade to Druid 31.0.2 or Druid 32.0.1, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.8% · higher than 78% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AD
Apache Druid · Apache Software Foundation
before 31.0.2; 32.0.0 · source: vendor
DR
Druid · Apache
before 31.0.2 · source: NVD
Affected product
AD
Apache Druid
Apache Software Foundation
More from Apache Druid
9.8
CVE-2026-23906
Apache Druid: Authentication Bypass via LDAP Anonymous Bind
9.8
CVE-2025-59390
Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly.