High severity · published Jul 12, 2025
CVE-2024-41169
The attacker can use the raft server protocol in an unauthenticated way
7.5
CVSS
0.7%
EPSS
No
On KEV
Description
The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files.
This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0.
Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 53% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ZE
Zeppelin · Apache
0.10.1 before 0.12.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-41169
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-41169
Patch
https://github.com/apache/zeppelin/pull/4841
Issue Tracking
https://issues.apache.org/jira/browse/ZEPPELIN-6101
Issue Tracking
https://lists.apache.org/thread/moyym04993c8owh4h0qj98r43tbo8qdd
www.openwall.com
http://www.openwall.com/lists/oss-security/2025/07/13/1
More from Zeppelin
9.8
CVE-2024-31866
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin
9.8
CVE-2024-31864
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin
9.8
CVE-2019-10095
bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings
8.8
CVE-2018-1317
In Apache Zeppelin prior to 0.8.0 the cron scheduler was enabled by default and could allow users to run paragraphs as other users without authentication
8.1
CVE-2017-12619
Apache Zeppelin prior to 0.7.3 was vulnerable to session fixation which allowed an attacker to hijack a valid user session
