Critical severity · published Apr 9, 2024
CVE-2024-31864
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin
9.8
CVSS
1.3%
EPSS
No
On KEV
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin. The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.3% · higher than 69% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ZE
Zeppelin · Apache
before 0.11.1 · source: NVD
Affected product
ZE
Zeppelin
Apache
More from Zeppelin
9.8
CVE-2024-31866
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin
9.8
CVE-2019-10095
bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings
8.8
CVE-2018-1317
In Apache Zeppelin prior to 0.8.0 the cron scheduler was enabled by default and could allow users to run paragraphs as other users without authentication
8.1
CVE-2017-12619
Apache Zeppelin prior to 0.7.3 was vulnerable to session fixation which allowed an attacker to hijack a valid user session
7.5
CVE-2024-41169
The attacker can use the raft server protocol in an unauthenticated way