Medium severity · published Jul 30, 2024
CVE-2024-37165
Discourse is an open source discussion platform
6.1
CVSS
0.4%
EPSS
No
On KEV
Description
Discourse is an open source discussion platform. Prior to 3.2.3 and 3.3.0.beta3, improperly sanitized Onebox data could lead to an XSS vulnerability in some situations. This vulnerability only affects Discourse instances which have disabled the default Content Security Policy. This vulnerability is fixed in 3.2.3 and 3.3.0.beta3.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 30% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DI
Discourse · Discourse
before 3.2.3; 3.3.0; 3.3.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-37165
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-37165
Patch
https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd
Patch
https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2
Vendor Advisory
https://github.com/discourse/discourse/security/advisories/GHSA-cx83-5p6x-9qh9
More from Discourse
9.9
CVE-2025-68662
FinalDestination hostname matching allows SSRF protection bypass
9.8
CVE-2025-53102
Discourse's WebAuthn challenge isn't cleared from user session after authentication
9.8
CVE-2025-48877
Discourse vulnerable to auto-executing of third-party code in embedded CodePen iframe
9.8
CVE-2023-47121
Discourse is an open source platform for community discussion
9.8
CVE-2021-41163
Discourse is an open source platform for community discussion
