Medium severity · published May 2, 2024
CVE-2024-32638
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from…
6.3
CVSS
1.1%
EPSS
No
On KEV
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0.
Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 65% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AP
Apisix · Apache
3.8.0; 3.9.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-32638
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-32638
Mailing List
http://www.openwall.com/lists/oss-security/2024/05/02/2
Mailing List
https://lists.apache.org/thread/ngvgxllw4zn4hgngkqw2o225kf9wotov
More from Apisix
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
7.5
CVE-2023-44487
HTTP/2 Rapid Reset Attack Vulnerability
9.8
CVE-2022-25757
In Apache APISIX before 2.13.0, when decoding JSON with duplicate keys, lua-cjson will choose the last occurred value as the result
9.3
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
