Medium severity · published Apr 9, 2024
CVE-2024-31867
Improper Input Validation vulnerability in Apache Zeppelin
6.5
CVSS
1.2%
EPSS
No
On KEV
Description
Improper Input Validation vulnerability in Apache Zeppelin.
The attackers can execute malicious queries by setting improper configuration properties to LDAP search filter.
This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.
Users are recommended to upgrade to version 0.11.1, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.2% · higher than 67% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ZE
Zeppelin · Apache
0.8.2 before 0.11.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-31867
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-31867
Mailing List
http://www.openwall.com/lists/oss-security/2024/04/09/12
Issue Tracking
https://github.com/apache/zeppelin/pull/4714
Mailing List
https://lists.apache.org/thread/s4scw8bxdhrjs0kg0lhb68xqd8y9lrtf
More from Zeppelin
9.8
CVE-2024-31866
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin
9.8
CVE-2024-31864
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin
9.8
CVE-2019-10095
bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings
8.8
CVE-2018-1317
In Apache Zeppelin prior to 0.8.0 the cron scheduler was enabled by default and could allow users to run paragraphs as other users without authentication
8.1
CVE-2017-12619
Apache Zeppelin prior to 0.7.3 was vulnerable to session fixation which allowed an attacker to hijack a valid user session
