Medium severity · published May 7, 2024
CVE-2024-28148
An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache…
4.3
CVSS
0.7%
EPSS
No
On KEV
Description
An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2.
Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
Low
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 53% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SU
Superset · Apache
before 4.0.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-28148
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-28148
Mailing List
https://lists.apache.org/thread/n27wlbd05oc6bgjh28d5pxzsrrph8dgo
More from Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
9.8
CVE-2024-53947
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset
9.8
CVE-2024-39887
An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands
9.8
CVE-2022-27479
Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests
9.8
CVE-2018-8021
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution
