Critical severity · published Jul 16, 2024
CVE-2024-39887
An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands
9.8
CVSS
4.4%
EPSS
No
On KEV
Description
An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection.
This issue affects Apache Superset: before 4.0.2.
Users are recommended to upgrade to version 4.0.2, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)4.4% · higher than 91% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SU
Superset · Apache
before 4.0.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-39887
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-39887
Mailing List
http://www.openwall.com/lists/oss-security/2024/07/16/5
Mailing List
https://lists.apache.org/thread/j55vm41jg3l0x6w49zrmvbf3k0ts5fqz
More from Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
9.8
CVE-2024-53947
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset
9.8
CVE-2022-27479
Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests
9.8
CVE-2018-8021
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution
8.8
CVE-2025-27696
Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions
