Low severity · published Oct 16, 2023
CVE-2023-45147
Discourse is an open source community platform
3.1
CVSS
0.3%
EPSS
No
On KEV
Description
Discourse is an open source community platform. In affected versions any user can create a topic and add arbitrary custom fields to a topic. The severity of this vulnerability depends on what plugins are installed and how the plugins uses topic custom fields. For a default Discourse installation with the default plugins, this vulnerability has no impact. The problem has been patched in the latest version of Discourse. Users are advised to update to version 3.1.1 if they are on the stable branch or 3.2.0.beta2 if they are on the beta branch. Users unable to upgrade should disable any plugins that access topic custom fields.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
High
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 25% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DI
Discourse · Discourse
through 3.1.1; 3.2.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-45147
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-45147
Vendor Advisory
https://github.com/discourse/discourse/security/advisories/GHSA-wm89-m359-f9qv
More from Discourse
9.9
CVE-2025-68662
FinalDestination hostname matching allows SSRF protection bypass
9.8
CVE-2025-53102
Discourse is an open-source community discussion platform
9.8
CVE-2025-48877
Discourse is an open-source discussion platform
9.8
CVE-2023-47121
Discourse is an open source platform for community discussion
9.8
CVE-2021-41163
Discourse is an open source platform for community discussion
