Medium severity · published Oct 16, 2023
CVE-2023-43659
Discourse is an open source platform for community discussion
5.4
CVSS
0.5%
EPSS
No
On KEV
Description
Discourse is an open source platform for community discussion. Improper escaping of user input allowed for Cross-site Scripting attacks via the digest email preview UI. This issue only affects sites with CSP disabled. This issue has been patched in the 3.1.1 stable release as well as the 3.2.0.beta1 release. Users are advised to upgrade. Users unable to upgrade should ensure CSP is enabled on the forum.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 41% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DI
Discourse · Discourse
through 3.1.1; 3.2.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-43659
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-43659
Third Party Advisory
https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP
Vendor Advisory
https://github.com/discourse/discourse/security/advisories/GHSA-g4qg-5q2h-m8ph
More from Discourse
9.9
CVE-2025-68662
FinalDestination hostname matching allows SSRF protection bypass
9.8
CVE-2025-53102
Discourse's WebAuthn challenge isn't cleared from user session after authentication
9.8
CVE-2025-48877
Discourse is an open-source discussion platform
9.8
CVE-2023-47121
Discourse is an open source platform for community discussion
9.8
CVE-2021-41163
Discourse is an open source platform for community discussion
