Medium severity · published Dec 27, 2022
CVE-2021-4291
A vulnerability was found in OpenMRS Admin UI Module up to 1.5.x
6.1
CVSS
1%
EPSS
No
On KEV
Description
A vulnerability was found in OpenMRS Admin UI Module up to 1.5.x. It has been declared as problematic. This vulnerability affects unknown code of the file omod/src/main/webapp/pages/metadata/locations/location.gsp. The manipulation leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is a7eefb5f69f6c50a3bffcb138bb8ea57cb41a9b6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216916.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 62% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AU
Admin UI Module · Openmrs
before 1.6.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-4291
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-4291
Patch
https://github.com/openmrs/openmrs-module-adminui/commit/a7eefb5f69f6c50a3bffcb138bb8ea57cb41a9b6
Patch
https://github.com/openmrs/openmrs-module-adminui/pull/61
Release Notes
https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.6.0
Permissions Required
https://vuldb.com/?ctiid.216916
Permissions Required
https://vuldb.com/?id.216916
More from Admin UI Module
6.1
CVE-2021-4292
A vulnerability was found in OpenMRS Admin UI Module up to 1.4.x
6.1
CVE-2020-36636
A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x
