Medium severity · published Aug 31, 2021
CVE-2021-39178
Next.js is a React framework
6.1
CVSS
1.1%
EPSS
No
On KEV
Description
Next.js is a React framework. Versions of Next.js between 10.0.0 and 11.0.0 contain a cross-site scripting vulnerability. In order for an instance to be affected by the vulnerability, the `next.config.js` file must have `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default or the instance is deployed on Vercel, the instance is not affected by the vulnerability. The vulnerability is patched in Next.js version 11.1.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 66% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NE
Next.js · Vercel
10.0.0 before 11.1.1 · source: NVD
Affected product
NE
Next.js
Vercel
More from Next.js
10.0
CVE-2025-55182
Meta React Server Components Remote Code Execution Vulnerability
9.1
CVE-2025-29927
Next.js is a React framework for building full-stack web applications
9.0
CVE-2026-75604
Next.js: Unauthenticated Remote Code Execution on windows-hosted servers
8.6
CVE-2026-44578
Next.js: Server-side request forgery in applications using WebSocket upgrades
8.2
CVE-2026-94482
Next.js: Denial of Service in App Router using Server Actions