Medium severity · published Jul 16, 2019
CVE-2019-1010018
Zammad GmbH Zammad 2.3.0 and earlier is affected by: Cross Site Scripting (XSS) - CWE-80
6.1
CVSS
1.3%
EPSS
No
On KEV
Description
Zammad GmbH Zammad 2.3.0 and earlier is affected by: Cross Site Scripting (XSS) - CWE-80. The impact is: Execute java script code on users browser. The component is: web app. The attack vector is: the victim must open a ticket. The fixed version is: 2.3.1, 2.2.2 and 2.1.3.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.3% · higher than 69% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ZA
Zammad · Zammad
2.1.0 through 2.1.2; 2.2.0 through 2.2.1; 2.3.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2019-1010018
CVE.org
https://www.cve.org/CVERecord?id=CVE-2019-1010018
Patch
https://github.com/zammad/zammad/compare/5c983f6...1a9af7d
Patch
https://github.com/zammad/zammad/compare/ea50d0c...238784d
Third Party Advisory
https://github.com/zammad/zammad/issues/1869
More from Zammad
9.8
CVE-2026-102489
Undisclosed RCE in Zammad v6.3 and higher
7.8
CVE-2026-102490
Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM package
9.8
CVE-2022-48021
A vulnerability in Zammad v5.3.0 allows attackers to execute arbitrary code or escalate privileges via a crafted message sent to the server
9.8
CVE-2022-35490
Zammad 5.2.0 is vulnerable to privilege escalation
9.8
CVE-2021-42090
An issue was discovered in Zammad before 4.1.1
