Home › Intelligence › Brief
VULNERABILITY BRIEF 🔴 Critical Vulnerability

Critical RCE in Flowise (CVE‑2025‑59528) Exploited in the Wild Threatens AI Development Platforms

Flowise, a popular open‑source low‑code AI platform, is being actively exploited via CVE‑2025‑59528, a CVSS 10 remote code execution flaw. Thousands of publicly exposed instances put downstream AI services at risk, creating a supply‑chain threat for organizations that rely on Flowise‑based agents.

Verisq™ Intelligence · 📅 April 07, 2026 · 📰 bleepingcomputer.com
🔴
Severity
Critical
VU
Type
Vulnerability
🎯
Confidence
High
🏢
Affected
1 sector(s)
✅
Actions
4 recommended
📰
Source
bleepingcomputer.com

Critical RCE in Flowise (CVE‑2025‑59528) Exploited in the Wild Threatens AI Development Platforms

What It Is — Flowise, an open‑source low‑code platform for building LLM‑driven agents, contains a maximum‑severity (CVSS 10) remote code execution flaw (CVE‑2025‑59528). The vulnerability resides in the CustomMCP node, which evaluates user‑supplied mcpServerConfig JavaScript without validation, allowing arbitrary code execution and file‑system access.

Exploitability — Active exploitation has been confirmed by VulnCheck’s Canary network, with malicious traffic observed from a single Starlink IP. Exploit samples, YARA rules, and network signatures are already being shared with customers.

Affected Products — Flowise ≤ 3.0.5 (all versions prior to 3.0.6). The issue is patched in 3.0.6; the current stable release is 3.1.1.

TPRM Impact —

  • Third‑party AI services built on vulnerable Flowise instances can become a conduit for ransomware, data exfiltration, or supply‑chain compromise.
  • Up to 15 k publicly exposed Flowise deployments increase the attack surface for any organization that integrates these instances into its workflow.

Recommended Actions —

  1. Verify Flowise version across all owned or vendor‑managed environments.
  2. Upgrade immediately to 3.1.1 (or at minimum 3.0.6).
  3. Restrict external network access to Flowise nodes; place them behind VPN or zero‑trust controls.
  4. Deploy VulnCheck‑provided YARA/network signatures or equivalent IDS/IPS rules.
  5. Conduct a focused asset inventory of AI/LLM tooling to assess downstream supply‑chain exposure.

Source: BleepingComputer

📰 Original Source
https://www.bleepingcomputer.com/news/security/max-severity-flowise-rce-vulnerability-now-exploited-in-attacks/ ↗

This Verisq Intelligence Brief is an independent analysis. Read the original reporting at the link above.

Vulnerability exposure

Is this CVE in your supply chain?

Verisq matches published vulnerabilities against the software your vendors run, so you know which relationships this touches before the next review.

See vendor exposure →