BI
Product
BIND
On CISA KEVExploited in the wild
184
CVEs
1
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 2High 62Medium 36Low 1
Watch
Add BIND to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2015-5477 In wildKEV | 7.5 | Jul 29 | ISC BIND Data Processing Errors Vulnerability Affected: 9.1.0 before 9.9.7; 9.10.0 before 9.10.2; 9.10.2 |
| CVE-2020-8616 | 8.6 | May 19 | A malicious actor who intentionally exploits this lack of effective limitation on the number of fetches performed when processing referrals can, through the use of specially… Affected: 9.0.0 through 9.11.18; 9.12.0 through 9.12.4; 9.13.0 through 9.13.7; 9.14.0 through 9.14.11; 9.15.0 through 9.15.6; 9.16.0 through 9.16.2; +12 more |
| CVE-2016-1286 | 8.6 | Mar 9 | named in ISC BIND 9.x before 9.9.8-P4 and 9.10.x before 9.10.3-P4 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a crafted signature… Affected: 9.0.0 before 9.9.8; 9.10.0 before 9.10.3; 9.9.8; 9.9.8; 9.9.8; 9.9.8; +6 more |
| CVE-2022-2881 | 8.2 | Sep 21 | The underlying bug might cause read past end of the buffer and either read memory it should not read, or crash the process Affected: 9.18.0 before 9.18.7; 9.19.0 before 9.19.5 |
| CVE-2020-8625 | 8.1 | Feb 17 | BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features Affected: 9.5.0 through 9.11.27; 9.12.0 through 9.16.11; 9.11.3; 9.11.5; 9.11.5; 9.11.6; +8 more |
| CVE-2017-3141 | 7.8 | Jan 16 | Windows service and uninstall paths are not quoted when BIND is installed Affected: 9.2.6 through 9.2.9; 9.3.2 through 9.3.6; 9.4.0 through 9.8.8; 9.9.0 through 9.9.10; 9.10.0 through 9.10.5; 9.11.0 through 9.11.1; +2 more |
| CVE-2001-0497 | 7.8 | Jul 21 | dnskeygen in BIND 8.2.4 and earlier, and dnssec-keygen in BIND 9.1.2 and earlier, set insecure permissions for a HMAC-MD5 shared secret key file used for DNS Transactional… Affected: through 8.2.4; 9.0 through 9.1.2 |
| CVE-2026-5946 | 7.5 | May 20 | Invalid handling of CLASS != IN Affected: 9.11.0 through 9.16.50; 9.18.0 before 9.18.49; 9.20.0 before 9.20.23; 9.21.0 before 9.21.22 |
| CVE-2026-3039 | 7.5 | May 20 | BIND 9 server memory exhaustion during GSS-API TKEY negotiation Affected: 9.0.0 through 9.16.50; 9.18.0 before 9.18.49; 9.20.0 before 9.20.23; 9.21.0 before 9.21.22 |
| CVE-2026-3104 | 7.5 | Mar 25 | Memory leak in code preparing DNSSEC proofs of non-existence Affected: 9.20.0 before 9.20.21; 9.21.0 before 9.21.20 |
| CVE-2026-1519 | 7.5 | Mar 25 | Excessive NSEC3 iterations cause high CPU load during insecure delegation validation Affected: 9.11.0 through 9.16.50; 9.18.0 before 9.18.47; 9.20.0 before 9.20.21; 9.21.0 before 9.21.20 |
| CVE-2023-50868 | 7.5 | Feb 14 | The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for… Affected: 9.0.0 before 9.16.48; 9.9.3 before 9.16.48; 9.18.0 before 9.18.24; 9.18.11 before 9.18.24; 9.19.0 before 9.19.21 |
| CVE-2023-50387 | 7.5 | Feb 14 | Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more… Affected: 9.0.0 through 9.16.46; 9.18.0 through 9.18.22; 9.19.0 through 9.19.20 |
| CVE-2023-6516 | 7.5 | Feb 13 | To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database Affected: 9.16.0 through 9.16.45; 9.16.8; 9.16.11; 9.16.12; 9.16.13; 9.16.14; +5 more |
| CVE-2023-5679 | 7.5 | Feb 13 | A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled Affected: 9.16.12 through 9.16.45; 9.18.0 through 9.18.21; 9.19.0 through 9.19.19; 9.16.12; 9.16.13; 9.16.14; +8 more |
| CVE-2023-5517 | 7.5 | Feb 13 | A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives… Affected: 9.12.0 through 9.16.45; 9.18.0 through 9.18.21; 9.19.0 through 9.19.19; 9.16.8; 9.16.11; 9.16.12; +10 more |
| CVE-2023-4408 | 7.5 | Feb 13 | The DNS message parsing code in `named` includes a section whose computational complexity is overly high Affected: 9.0.0 through 9.16.45; 9.18.0 through 9.18.21; 9.19.0 through 9.19.19; 9.9.3; 9.16.8; 9.16.11; +10 more |
| CVE-2023-4236 | 7.5 | Sep 20 | A flaw in the networking code handling DNS-over-TLS queries may cause `named` to terminate unexpectedly due to an assertion failure Affected: 9.18.0 before 9.18.18; 9.18.11; 9.18.18 |
| CVE-2023-3341 | 7.5 | Sep 20 | The code that processes control channel messages sent to `named` calls certain functions recursively during packet parsing Affected: 9.2.0 before 9.16.44; 9.18.0 before 9.18.19; 9.19.0 before 9.19.17; 9.9.3; 9.9.12; 9.9.13; +28 more |
| CVE-2023-2911 | 7.5 | Jun 21 | If the `recursive-clients` quota is reached on a BIND 9 resolver configured with both `stale-answer-enable yes;` and `stale-answer-client-timeout 0;`, a sequence of… Affected: 9.16.33 through 9.16.41; 9.16.33 through 9.16.41; 9.18.7 through 9.18.15; 9.18.11 through 9.18.15 |
| CVE-2023-2829 | 7.5 | Jun 21 | A `named` instance configured to run as a DNSSEC-validating recursive resolver with the Aggressive Use of DNSSEC-Validated Cache (RFC 8198) option (`synth-from-dnssec`) enabled… Affected: 9.16.8 through 9.16.41; 9.18.11 through 9.18.15 |
| CVE-2023-2828 | 7.5 | Jun 21 | Every `named` instance configured to run as a recursive resolver maintains a cache database holding the responses to the queries it has recently sent to authoritative servers Affected: 9.11.0 through 9.16.41; 9.11.3 through 9.16.41; 9.18.0 through 9.18.15; 9.18.11 through 9.18.15; 9.19.0 through 9.19.13 |
| CVE-2022-3924 | 7.5 | Jan 26 | This issue can affect BIND 9 resolvers with `stale-answer-enable yes;` that also make use of the option `stale-answer-client-timeout`, configured with a value greater than zero Affected: 9.16.12 before 9.16.37; 9.18.0 before 9.18.11; 9.19.0 before 9.19.9; 9.16.12; 9.16.13; 9.16.14; +3 more |
| CVE-2022-3736 | 7.5 | Jan 26 | BIND 9 resolver can crash when stale cache and stale answers are enabled, option `stale-answer-client-timeout` is set to a positive integer, and the resolver receives an RRSIG… Affected: 9.16.12 before 9.16.37; 9.18.0 before 9.18.11; 9.19.0 before 9.19.9; 9.16.11; 9.16.13; 9.16.14; +3 more |
| CVE-2022-3488 | 7.5 | Jan 26 | Processing of repeated responses to the same query, where both responses contain ECS pseudo-options, but where the first is broken in some way, can cause BIND to exit with an… Affected: 9.11.4; 9.11.37; 9.16.8; 9.16.36 |
| CVE-2022-3094 | 7.5 | Jan 26 | Sending a flood of dynamic DNS updates may cause `named` to allocate large amounts of memory Affected: 9.16.0 before 9.16.37; 9.18.0 before 9.18.11; 9.19.0 before 9.19.9; 9.16.8; 9.16.11; 9.16.13; +4 more |
| CVE-2022-3080 | 7.5 | Sep 21 | By sending specific queries to the resolver, an attacker can cause named to crash Affected: 9.16.14 before 9.16.33; 9.18.0 before 9.18.7; 9.19.0 before 9.19.5; 9.16.14; 9.16.21; 9.16.32 |
| CVE-2022-38178 | 7.5 | Sep 21 | By spoofing the target resolver with responses that have a malformed EdDSA signature, an attacker can trigger a small memory leak Affected: 9.9.12 through 9.9.13; 9.10.7 through 9.10.8; 9.11.3 through 9.16.32; 9.11.3; 9.11.3; 9.11.5; +19 more |
| CVE-2022-38177 | 7.5 | Sep 21 | By spoofing the target resolver with responses that have a malformed ECDSA signature, an attacker can trigger a small memory leak Affected: 9.8.4 through 9.16.32; 9.9.3; 9.9.3; 9.9.12; 9.9.13; 9.10.5; +22 more |
| CVE-2022-2906 | 7.5 | Sep 21 | An attacker can leverage this flaw to gradually erode available memory to the point where named crashes for lack of resources Affected: 9.18.0 before 9.18.7; 9.19.0 before 9.19.5 |
| CVE-2022-1183 | 7.5 | May 19 | On vulnerable configurations, the named daemon may, in some circumstances, terminate with an assertion failure Affected: 9.18.0 through 9.18.2; 9.19.0 |
| CVE-2022-0635 | 7.5 | Mar 23 | Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion… Affected: 9.18.0 |
| CVE-2022-0667 | 7.5 | Mar 22 | When the vulnerability is triggered the BIND process will exit Affected: 9.18.0 |
| CVE-2021-25218 | 7.5 | Aug 18 | In BIND 9.16.19, 9.17.16 Affected: 9.16.19; 9.17.16; 9.17.16 |
| CVE-2021-25215 | 7.5 | Apr 29 | In BIND 9.0.0 -> 9.11.29, 9.12.0 -> 9.16.13, and versions BIND 9.9.3-S1 -> 9.11.29-S1 and 9.16.8-S1 -> 9.16.13-S1 of BIND Supported Preview Edition, as well as release versions… Affected: 9.0.0 before 9.11.31; 9.12.0 before 9.16.15; 9.17.0 before 9.17.12; 9.9.3; 9.9.12; 9.9.13; +16 more |
| CVE-2020-8623 | 7.5 | Aug 21 | In BIND 9.10.0 -> 9.11.21, 9.12.0 -> 9.16.5, 9.17.0 -> 9.17.3, also affects 9.10.5-S1 -> 9.11.21-S1 of the BIND 9 Supported Preview Edition, An attacker that can reach a… Affected: 9.10.0 through 9.11.21; 9.12.1 through 9.16.5; 9.17.0 through 9.17.3; 9.10.5; 9.11.21 |
| CVE-2020-8621 | 7.5 | Aug 21 | In BIND 9.14.0 -> 9.16.5, 9.17.0 -> 9.17.3, If a server is configured with both QNAME minimization and 'forward first' then an attacker who can send queries to it may be able to… Affected: 9.14.0 through 9.16.5; 9.17.0 through 9.17.3 |
| CVE-2020-8620 | 7.5 | Aug 21 | In BIND 9.15.6 -> 9.16.5, 9.17.0 -> 9.17.3, An attacker who can establish a TCP connection with the server and send data on that connection can exploit this to trigger the… Affected: 9.15.6 through 9.16.5; 9.17.0 through 9.17.3; 9.9.12; 9.9.13; 9.11.3; 9.11.21 |
| CVE-2019-6477 | 7.5 | Nov 26 | With pipelining enabled each incoming query on a TCP connection requires a similar resource allocation to a query received via UDP or via TCP without pipelining enabled Affected: 9.11.7 through 9.11.12; 9.14.1 through 9.14.7; 9.15.0 through 9.15.5; 9.11.5; 9.11.6; 9.11.6; +3 more |
| CVE-2018-5742 | 7.5 | Oct 30 | While backporting a feature for a newer branch of BIND9, RedHat introduced a path leading to an assertion failure in buffer.c:420 Affected: 9.9.4-65 through 9.9.4-72 |
| CVE-2019-6476 | 7.5 | Oct 17 | A defect in code added to support QNAME minimization can cause named to exit with an assertion failure if a forwarder returns a referral rather than resolving the query Affected: 9.14.0 through 9.14.6; 9.15.0 through 9.15.4 |
| CVE-2019-6475 | 7.5 | Oct 17 | Mirror zones are a BIND feature allowing recursive servers to pre-cache zone data provided by other servers Affected: 9.14.0 through 9.14.6; 9.15.0 through 9.15.4 |
| CVE-2019-6469 | 7.5 | Oct 9 | An error in the EDNS Client Subnet (ECS) feature for recursive resolvers can cause BIND to exit with an assertion failure when processing a response that has malformed RRSIGs Affected: 9.10.5; 9.11.6 |
| CVE-2019-6468 | 7.5 | Oct 9 | In BIND Supported Preview Edition, an error in the nxdomain-redirect feature can occur in versions which support EDNS Client Subnet (ECS) features Affected: 9.10.5; 9.11.5 |
| CVE-2019-6467 | 7.5 | Oct 9 | A programming error in the nxdomain-redirect feature can cause an assertion failure in query.c if the alternate namespace used by nxdomain-redirect is a descendant of a zone that… Affected: 9.12.0 through 9.12.4; 9.13.0 through 9.13.7; 9.14.0 |
| CVE-2018-5744 | 7.5 | Oct 9 | A failure to free memory can occur when processing messages having a specific combination of EDNS options Affected: 9.10.7 before 9.10.8; 9.11.3 before 9.11.5; 9.12.0 before 9.12.3; 9.13.0 before 9.13.6; 9.10.7; 9.10.8; +10 more |
| CVE-2018-5743 | 7.5 | Oct 9 | By design, BIND is intended to limit the number of TCP clients that can be connected at any given time Affected: 9.9.0 through 9.10.8; 9.11.0 through 9.11.6; 9.12.0 through 9.12.4; 9.13.0 through 9.13.7; 9.9.3; 9.10.8; +3 more |
| CVE-2018-5738 | 7.5 | Jan 16 | Some versions of BIND can improperly permit recursive query service to unauthorized clients Affected: 9.9.12; 9.9.12; 9.10.7; 9.10.7; 9.11.3; 9.11.3; +11 more |
| CVE-2018-5740 | 7.5 | Jan 16 | A flaw in the "deny-answer-aliases" feature can cause an assertion failure in named Affected: 9.7.0 before 9.8.8; 9.9.0 before 9.9.13; 9.10.0 before 9.10.8; 9.11.0 before 9.11.4; 9.12.0 before 9.12.2; 9.13.0 before 9.13.2 |
| CVE-2018-5737 | 7.5 | Jan 16 | BIND 9.12's serve-stale implementation can cause an assertion failure in rbtdb.c or other undesirable behavior, even if serve-stale is not enabled. Affected: 9.12.0; 9.12.1 |
