High severity · published Sep 24, 2026
CVE-2026-96883
Type confusion in AWS pgcollection allows remote code execution
8.8
CVSS
0.6%
EPSS
No
On KEV
Description
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions.
To remediate this issue, users should upgrade to version 2.1.2 or later.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 51% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PG
pgcollection · AWS
2.0.0 through 2.1.1 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-96883
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-96883
aws.amazon.com
https://aws.amazon.com/security/security-bulletins/2026-118-aws/
github.com
https://github.com/aws/pgcollection/releases/tag/v2.1.2
github.com
https://github.com/aws/pgcollection/security/advisories/GHSA-g539-cj32-hv6r
