Medium severity · published Sep 7, 2026
CVE-2026-86244
FastAdmin User Controller User.php login cross site scripting
4.3
CVSS
0.5%
EPSS
No
On KEV
Description
A security vulnerability has been detected in FastAdmin up to 1.2.0.20210401_beta. Affected is the function register/login of the file application/index/controller/User.php of the component User Controller. Such manipulation of the argument url leads to cross site scripting. The attack may be performed from remote. The exploit has been disclosed publicly and may be used. Upgrading to version 1.2.1.20210731_beta is able to address this issue. The name of the patch is b3d32e2bf3637488cfe2fc58a27a9d2475b2b51b. It is recommended to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 41% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
FastAdmin · Fastadmin
1.2.0.20210401_beta · source: vendor
Affected product
FA
FastAdmin
Fastadmin
More from FastAdmin
9.8
CVE-2021-43117
fastadmin v1.2.1 is affected by a file upload vulnerability which allows arbitrary code execution through shell access
8.8
CVE-2020-25967
The member center function in fastadmin V1.0.0.20200506_beta is vulnerable to a Server-Side Template Injection (SSTI) vulnerability
8.8
CVE-2019-17431
An issue was discovered in fastadmin 1.0.0.20190705_beta
8.8
CVE-2019-11077
FastAdmin V1.0.0.20190111_beta has a CSRF vulnerability to add a new admin user via the admin/auth/admin/add?dialog=1 URI
7.5
CVE-2024-7928
A vulnerability, which was classified as problematic, has been found in FastAdmin up to 1.3.3.20220121