Medium severity · published Aug 30, 2026
CVE-2026-82589
Open5GS N1-N2 Message namf-handler.c amf_namf_comm_handle_n1_n2_message_transfer denial of service
4.3
CVSS
0.5%
EPSS
No
On KEV
Description
A security flaw has been discovered in Open5GS up to 2.7.7. Impacted is the function amf_namf_comm_handle_n1_n2_message_transfer of the file src/amf/namf-handler.c of the component N1-N2 Message Handler. Performing a manipulation of the argument N1N2MessageTransferReqData.n2InfoContainer.smInfo.n2InfoContent.ngapIeType results in denial of service. The attack may be initiated remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 2.8.0 is recommended to address this issue. The patch is named abf8a836564b966b5141110fc25ed413c4f17522. It is advisable to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 46% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OP
Open5GS · Open5gs
2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.5; +2 more · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-82589
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-82589
github.com
https://github.com/open5gs/open5gs/
github.com
https://github.com/open5gs/open5gs/commit/abf8a836564b966b5141110fc25ed413c4f17522
github.com
https://github.com/open5gs/open5gs/issues/4396
github.com
https://github.com/open5gs/open5gs/releases/tag/v2.8.0
vuldb.com
https://vuldb.com/cve/CVE-2026-82589
vuldb.com
https://vuldb.com/submit/891892
More from Open5GS
9.8
CVE-2026-2522
Open5GS MME esm-build.c memory corruption
9.8
CVE-2026-2521
Open5GS SGW-C sgwc_s5c_handle_create_session_response memory corruption
9.8
CVE-2024-40130
open5gs v2.6.4 is vulnerable to Buffer Overflow
9.8
CVE-2024-40129
Open5GS v2.6.4 is vulnerable to Buffer Overflow
9.8
CVE-2021-28122
A request-validation issue was discovered in Open5GS 2.1.3 through 2.2.x before 2.2.1
