Critical severity · published Sep 16, 2026
CVE-2026-77405
RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser
9.4
CVSS
0.3%
EPSS
No
On KEV
Description
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 21% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AM
amqp091-go · rabbitmq
< 1.13.0 · source: vendor
Affected product
AM
amqp091-go
rabbitmq
More from amqp091-go
9.5
CVE-2026-77411
RabbitMQ amqp091-go: Protocol Desynchronization and Frame Injection via Integer Overflow in readLongstr
9.1
CVE-2026-77408
RabbitMQ amqp091-go: Silent Data Truncation and State Corruption via Shortstr Integer Overflow
8.9
CVE-2026-77412
RabbitMQ amqp091-go: Denial of Service via Malicious Field Length in AMQP Client
8.9
CVE-2026-77410
RabbitMQ amqp091-go: Resource Exhaustion (OOM) via Unbounded Body Buffer Allocation
8.9
CVE-2026-77403
RabbitMQ amqp091-go: Denial of Service via Sub-Spec Frame Size Negotiation