High severity · published Aug 26, 2026
CVE-2026-55182
LibreNMS: Remote Code Execution by Signal Alert Transportation Module
8.6
CVSS
1.6%
EPSS
No
On KEV
Description
LibreNMS is a network monitoring system. In versions from 21.6.0 up to 26.5.0, the Signal alert transport is vulnerable to command injection because the signal-cli path and the Recipient field of an alert transport entry are insufficiently escaped before being passed to an exec call. An authenticated administrator can craft a transport entry whose Recipient contains shell metacharacters and whose path points to the bundled composer_wrapper.php script, which itself passes attacker-controlled input to further unsafe exec calls. By chaining these calls, the administrator can execute arbitrary operating-system commands on the LibreNMS host. This issue is fixed in version 26.5.0.
Exploitation
Is it being used?
Exploit prediction (EPSS)1.6% · higher than 76% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
LI
librenms · librenms
>= 21.6.0, < 26.5.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-55182
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-55182
github.com
https://github.com/librenms/librenms/commit/868e3b966a
github.com
https://github.com/librenms/librenms/releases/tag/26.5.0
github.com
https://github.com/librenms/librenms/security/advisories/GHSA-c9fv-cgmm-2wg7
More from librenms
9.8
CVE-2026-86426
LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion
9.8
CVE-2022-4070
Insufficient Session Expiration in GitHub repository librenms/librenms prior to 22.10.0
9.8
CVE-2022-29712
LibreNMS v22.3.0 was discovered to contain multiple command injection vulnerabilities via the service_ip, hostname, and service_param parameters
9.8
CVE-2021-44278
Librenms 21.11.0 is affected by a path manipulation vulnerability in includes/html/pages/device/showconfig.inc.php
9.8
CVE-2019-10665
An issue was discovered in LibreNMS through 1.47
