Critical severity · published Jun 5, 2026
CVE-2026-45758
Malicious code in guardrails-ai 0.10.1 (supply chain compromise)
9.6
CVSS
0.3%
EPSS
No
On KEV
Description
Guardrails AI is a Python framework that helps build AI applications. On May 11, 2026 at approximately 6:00 PM Pacific, an attacker published a malicious version of `guardrails-ai` (0.10.1) to PyPI. Aany user who installed `guardrails-ai==0.10.1` from PyPI on May 11, 2026 may be affected. Security researchers identified the malicious package within approximately 2 hours of publication, and PyPI quarantined the repository. Based on our telemetry, Guardrails AI maintainers have observed no requests to Guardrails AI infrastructure originating from the malicious 0.10.1 version, and a review of system and access logs has produced no evidence of user data exfiltration through their systems. Users should upgrade to version 0.10.2 or downgrade to version 0.10.0, both of which are unaffected. Those who installed version 0.10.1 should rotate any credentials accessible from their machine (GitHub PATs, cloud provider keys, package registry tokens, API keys) and audit their GitHub account for unauthorized workflows or repositories.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 20% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
GU
guardrails · guardrails-ai
= 0.10.1 · source: vendor
GA
Guardrails AI · Guardrailsai
0.10.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-45758
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-45758
Vendor Advisory
https://github.com/guardrails-ai/guardrails/blob/main/SECURITY_ADVISORY.md
Issue Tracking
https://github.com/guardrails-ai/guardrails/issues/1473
Mitigation
https://github.com/guardrails-ai/guardrails/security/advisories/GHSA-xmpw-2vmm-p4p6
More from guardrails
7.8
CVE-2024-45858
An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files
