Medium severity · published May 14, 2026
CVE-2026-45205
Apache Commons Configuration: StackOverflowError for YAML input with cycles
5.3
CVSS
0.5%
EPSS
No
On KEV
Description
Uncontrolled Recursion vulnerability in Apache Commons.
When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles.
This issue affects Apache Commons: from 2.2 before 2.15.0.
Users are recommended to upgrade to version 2.15.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 40% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AC
Apache Commons Configuration · Apache Software Foundation
2.2 before 2.15.0 · source: vendor
CC
Commons Configuration · Apache
2.2 before 2.15.0 · source: NVD
Affected product
AC
Apache Commons Configuration
Apache Software Foundation
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-45205
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-45205
Issue Tracking
https://github.com/apache/commons-configuration/pull/634
Mailing List
https://lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk
Mailing List
http://www.openwall.com/lists/oss-security/2026/05/14/5
