High severity · published Jul 8, 2026
CVE-2026-44160
Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`
7.5
CVSS
0.6%
EPSS
No
On KEV
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's in_http and in_forward plugins support gzip-compressed data but enforce limits only on compressed payloads through settings such as body_size_limit and chunk_size_limit, allowing crafted compressed payloads to decompress in memory to an excessive size and cause denial of service through memory exhaustion. This issue is fixed in version 1.19.3.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 49% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FL
fluentd · fluent
< 1.19.3 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-44160
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-44160
Patch
https://github.com/fluent/fluentd/commit/f5f2b7cddf8aab3932e6dec9fa367a5f3eb27e10
Issue Tracking
https://github.com/fluent/fluentd/pull/5393
Product
https://github.com/fluent/fluentd/releases/tag/v1.19.3
Mitigation
https://github.com/fluent/fluentd/security/advisories/GHSA-j9cw-hwqf-85w7
More from fluentd
9.8
CVE-2026-44024
Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder
9.8
CVE-2022-39379
Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)
7.5
CVE-2026-44025
Fluentd: Exposure of Sensitive Information via Monitor Agent API
7.2
CVE-2026-44161
Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`
