High severity · published Apr 23, 2026
CVE-2026-41271
Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains
8.3
CVSS
0.2%
EPSS
No
On KEV
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 14% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FL
Flowise · FlowiseAI
< 3.1.0 · source: vendor, NVD
FL
flowise-components · FlowiseAI
< 3.1.0 · source: vendor
Affected product
FL
Flowise
FlowiseAI
More from Flowise
10.0
CVE-2026-70478
Flowise: Unauthenticated OAuth2 token refresh endpoint returns access tokens — enables token theft for any connected service
10.0
CVE-2025-59528
Flowise has Remote Code Execution vulnerability
9.9
CVE-2026-73602
Flowise before 3.1.3 Sandbox Escape to RCE
9.9
CVE-2026-67622
Flowise 3.1.4 IDOR in OpenAI Assistants Integration
9.9
CVE-2026-56274
Flowise - Remote Code Execution via MCP Security Bypass in validateCommandFlags and validateArgsForLocalFileAccess