High severity · published May 9, 2026
CVE-2026-41163
bubblewrap vulnerable to privilege escalation in setuid mode via ptrace
7.0
CVSS
0.3%
EPSS
No
On KEV
Description
bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
High
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 20% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BU
bubblewrap · containers
>= 0.11.0, < 0.11.2 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-41163
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-41163
github.com
https://github.com/containers/bubblewrap/releases/tag/v0.11.2
github.com
https://github.com/containers/bubblewrap/security/advisories/GHSA-xq78-7hw4-5jvp
access.redhat.com
https://access.redhat.com/security/cve/CVE-2026-41163
bugzilla.redhat.com
https://bugzilla.redhat.com/show_bug.cgi?id=2468439
security.access.redhat.com
https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41163.json
