Low severity · published May 29, 2026
CVE-2026-33386
XSS in QuickCMS
2.3
CVSS
0.2%
EPSS
No
On KEV
Description
QuickCMS is vulnerable to Cross-Site Scripting (XSS) through its insecure HTTP-based plugin‑fetching mechanism. A malicious attacker can perform a Man‑in‑the‑Middle (MITM) attack by impersonating the opensolution.org server and serving arbitrary HTML or JavaScript at the plugin list endpoint. When a user accesses the plugin page, the malicious content is automatically fetched, rendered, and executed. This issue was fixed in a patch to version 6.8 published on 15.05.2026, deployments without this patch are still vulnerable.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 8% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
QU
QuickCMS · OpenSolution
through 6.8 · source: vendor
Affected product
QU
QuickCMS
OpenSolution
More from QuickCMS
8.6
CVE-2025-12465
Blind SQL Injection in QuickCMS
7.5
CVE-2025-9982
Hard-coded admin credentials in Quick.CMS
5.1
CVE-2026-1468
Cross-Site Request Forgery in QuickCMS
4.8
CVE-2026-33384
Session Fixation in QuickCMS
4.8
CVE-2025-10018
Multiple Stored XSS in QuickCMS