High severity · published Apr 14, 2026
CVE-2026-33019
libsixel: Integer overflow leads to Out-of-bounds Read in img2sixel
7.1
CVSS
0.3%
EPSS
No
On KEV
Description
libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. Versions 1.8.7 and prior contain an integer overflow leading to an out-of-bounds heap read in the --crop option handling of img2sixel, where positive coordinates up to INT_MAX are accepted without overflow-safe bounds checking. In sixel_encoder_do_clip(), the expression clip_w + clip_x overflows to a large negative value when clip_x is INT_MAX, causing the bounds guard to be skipped entirely, and the unclamped coordinate is passed through sixel_frame_clip() to clip(), which computes a source pointer far beyond the image buffer and passes it to memmove(). An attacker supplying a specially crafted crop argument with any valid image can trigger an out-of-bounds read in the heap, resulting in a reliable crash and potential information disclosure. This issue has been fixed in version 1.8.7-r1.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 17% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
LI
libsixel · saitoha
< 1.8.7-r1 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-33019
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-33019
Release Notes
https://github.com/saitoha/libsixel/releases/tag/v1.8.7-r1
Exploit
https://github.com/saitoha/libsixel/security/advisories/GHSA-c854-ffg9-g72c
More from libsixel
9.8
CVE-2019-19638
An issue was discovered in libsixel 1.8.2
9.8
CVE-2019-19637
An issue was discovered in libsixel 1.8.2
9.8
CVE-2019-19636
An issue was discovered in libsixel 1.8.2
9.8
CVE-2019-19635
An issue was discovered in libsixel 1.8.2
8.8
CVE-2022-27046
libsixel 1.8.6 suffers from a Heap Use After Free vulnerability in in libsixel/src/dither.c:388
