Medium severity · published Sep 2, 2026
CVE-2026-32773
Apache Spark: XSS Vulnerability in Spark Web 3.5.4
6.1
CVSS
0.4%
EPSS
No
On KEV
Description
There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 36% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AS
Apache Spark · Apache Software Foundation
3.0.0 before 3.5.8 · source: vendor
SP
Spark · Apache
3.0.0 before 3.5.8 · source: NVD
Affected product
AS
Apache Spark
Apache Software Foundation
More from Apache Spark
8.8
CVE-2022-33891
Apache Spark shell command injection vulnerability via Spark UI
8.8
CVE-2025-54920
Apache Spark: Spark History Server Code Execution Vulnerability
5.9
CVE-2024-23945
Apache Hive, Apache Spark, Apache Spark: CookieSigner exposes the correct signature when message verification fails
5.5
CVE-2018-11760
When using PySpark , it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application
5.4
CVE-2022-31777
Apache Spark XSS vulnerability in log viewer UI Javascript