High severity · published Apr 9, 2026
CVE-2026-29146
Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default
7.5
CVSS
8.8%
EPSS
No
On KEV
Description
Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.
Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)8.8% · higher than 95% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TO
Tomcat · Apache
11.0.0-M1 through 11.0.18; 10.0.0-M1 through 10.1.52; 9.0.13 through 9.0.115; 8.5.38 through 8.5.100; 7.0.100 through 7.0.109 · source: vendor, NVD
RH
Red Hat Enterprise Linux 10 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 10.0 Extended Update Support · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 6 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 7 Extended Lifecycle Support · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 8 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 8.8 Telecommunications Update Service · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 9 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux 9.6 Extended Update Support · Red Hat
All versions, or not specified · source: CISA
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-29146
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-29146
Mailing List
https://lists.apache.org/thread/lzt04z2pb3dc5tk85obn80xygw3z1p0w
Mailing List
http://www.openwall.com/lists/oss-security/2026/04/09/24
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:20405
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:20406
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:36787
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:36788
More from Tomcat
9.8
CVE-2025-24813
Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
9.8
CVE-2020-1938
Apache Tomcat Improper Privilege Management Vulnerability
9.8
CVE-2016-8735
Remote code execution is possible with Apache Tomcat before 6.0.48, 7.x before 7.0.73, 8.x before 8.0.39, 8.5.x before 8.5.7, and 9.x before 9.0.0.M12 if…
8.1
CVE-2017-12617
When running Apache Tomcat versions 9.0.0.M1 to 9.0.0, 8.5.0 to 8.5.22, 8.0.0.RC1 to 8.0.46 and 7.0.0 to 7.0.81 with HTTP PUTs enabled (e.g
8.1
CVE-2017-12615
When running Apache Tomcat 7.0.0 to 7.0.79 on Windows with HTTP PUTs enabled (e.g
