High severity · published Feb 17, 2026
CVE-2026-24734
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat
7.5
CVSS
0.6%
EPSS
No
On KEV
Description
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat.
When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed.
This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114.
The following versions were EOL at the time the CVE was created but are
known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected.
Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue.
Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 47% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TO
Tomcat · Apache
9.0.83 before 9.0.115; 10.1.1 before 10.1.52; 11.0.1 before 11.0.18; 10.1.0; 10.1.0; 10.1.0; +34 more · source: NVD
TN
Tomcat Native · Apache
1.3.0 before 1.3.5; 2.0.0 before 2.0.12 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-24734
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-24734
Issue Tracking
https://lists.apache.org/thread/292dlmx3fz1888v6v16221kpozq56gml
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:19054
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:26323
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:36790
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:5611
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:5612
More from Tomcat
9.8
CVE-2025-24813
Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
9.8
CVE-2020-1938
Apache Tomcat Improper Privilege Management Vulnerability
9.8
CVE-2016-8735
Remote code execution is possible with Apache Tomcat before 6.0.48, 7.x before 7.0.73, 8.x before 8.0.39, 8.5.x before 8.5.7, and 9.x before 9.0.0.M12 if…
8.1
CVE-2017-12617
When running Apache Tomcat versions 9.0.0.M1 to 9.0.0, 8.5.0 to 8.5.22, 8.0.0.RC1 to 8.0.46 and 7.0.0 to 7.0.81 with HTTP PUTs enabled (e.g
8.1
CVE-2017-12615
When running Apache Tomcat 7.0.0 to 7.0.79 on Windows with HTTP PUTs enabled (e.g
