High severity · published Jan 16, 2026
CVE-2026-23490
pyasn1 is a generic ASN.1 library for Python
7.5
CVSS
0.8%
EPSS
No
On KEV
Description
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.2, a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. This vulnerability is fixed in 0.6.2.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 55% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
11.0 · source: NVD
PY
Pyasn1 · Pyasn1
before 0.6.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-23490
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-23490
Patch
https://github.com/pyasn1/pyasn1/commit/3908f144229eed4df24bd569d16e5991ace44970
Product
https://github.com/pyasn1/pyasn1/releases/tag/v0.6.2
Vendor Advisory
https://github.com/pyasn1/pyasn1/security/advisories/GHSA-63vm-454h-vhhq
Vendor Advisory
https://lists.debian.org/debian-lts-announce/2026/02/msg00002.html
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:13508
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:13512
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
