Medium severity · published Feb 6, 2026
CVE-2026-22592
Gogs is Vulnerable to Denial of Service
6.5
CVSS
0.4%
EPSS
No
On KEV
Description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, an authenticated user can cause a DOS attack. If one of the repo files is deleted before synchronization, it will cause the application to crash. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 32% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
GO
gogs · gogs
< 0.14.0+dev; < 0.13.4 · source: vendor, NVD
Affected product
GO
gogs
gogs
More from gogs
8.8
CVE-2025-8110
File overwrite in file update API in Gogs
10.0
CVE-2026-52813
Gogs: Path Traversal in organization name results in RCE through Git hooks
9.9
CVE-2026-52806
Gogs: RCE via git rebase --exec argument injection in pull request merge
9.9
CVE-2024-39932
Gogs through 0.13.0 allows argument injection during the previewing of changes
9.9
CVE-2024-39931
Gogs through 0.13.0 allows deletion of internal files