High severity · published Aug 17, 2026
CVE-2026-19589
Packer vulnerable to arbitrary file write via crafted plugin archive during installation
7.1
CVSS
0.2%
EPSS
No
On KEV
Description
Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
High
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 9% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PA
Packer · HashiCorp
1.7.0 before 1.16.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-19589
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-19589
discuss.hashicorp.com
https://discuss.hashicorp.com/t/hcsec-2026-29-packer-vulnerable-to-arbitrary-file-write-via-crafted-plugin-archive-during-installation/77654
More from Packer
5.3
CVE-2018-15869
An Amazon Web Services (AWS) developer who does not specify the --owners flag when describing images via AWS CLI, and therefore not properly validating source software per AWS…
