High severity · published Jul 24, 2026
CVE-2026-15810
Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover
8.7
CVSS
0.5%
EPSS
No
On KEV
Description
A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 39% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
LO
Looker · Google Cloud
before 25.6.103; before 25.12.65; before 25.18.68; before 26.0.66; before 26.2.47; before 26.4.36; +10 more · source: vendor
Affected product
LO
Looker
Google Cloud
More from Looker
9.2
CVE-2025-12414
Looker account compromise via punycode homograph attack
7.7
CVE-2025-12741
Arbitrary File Write in Denodo dialect of Looker allows Remote Code Execution
7.7
CVE-2025-12740
Remote Command Execution in Looker via IBM DB2 JDBC drive
7.5
CVE-2025-12742
Remote Code Execution in Looker via Teradata JDBC Driver
7.3
CVE-2025-12739
Cross-Site Scripting (XSS) in Looker's Extension Loader leading to Admin Account Compromise